Trouble with SampleKernel from video tutorial 3

Great tutorial. I am on the getting started video lesson 3
I built the kernel.asm, and got it running in virtualbox perfectly. In the kernel.asm given in the resources folder,
I'm changing the line from
mov EAX, 0x2000
mov EAX, 0x023F
then build, and am seeing no change when i restart my vm. I expected this to change the output from a green background with no characters to a black background with green question marks.


  • edited September 2015
    When i change any bit of code in the kernel.asm file, even just changing mov EAX, 0x2000 to mov EAX, 0x3000, when i run built.bat i get the error:

    Executing NASM...
    Kernel.asm:1: error: label or instruction expected at start of line

    and then the kernel.o and kernel.bin files are removed.
  • edited September 2015
    I have fixed my problems, turns out it was a bug with notepad. Thats what i get for not using a better editor. I opened it in sublime, saved it and it worked fine. (╯°□°)╯︵ ┻━┻
  • Hi,

    Thanks for the feedback! Glad you liked the tutorial and that you were able to resolve your issue. This sounds like a character/file encoding issue, which Sublime is better at handling than notepad.

    We recommend using Notepad++ as it is very good for controlling things like this (and has reasonable ASM syntax highlighting for various different assemblers).

    Best regards,
This discussion has been closed.